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GSA Image Analyser 

1. General information 
 
The GSA Image Analyser is a tool specially designed for the creation and analysis of 2D 
image objects. The objects can be identified on the basis of their specific colouration and be 
distinguished  in this way from their environment. For an analysis the following automatic 
functions are provided : 

· number of identified objects 
· 2D object area computation  
· object area ratio to total area (density) 
· determination of object length 
· counting of intersection points in a raster  
· visualization of colour distribution 

 
Additional functions : 

· manual counting by marking areas 
· manual counting by image splitting 
· creation of images 
· image processing functions 

 

2. Description of functions 

2.1 Creation of graphic data 
 
To create the required graphic data a Twain interface is provided. By means of this interface 
all optical devices such as scanner, digital cameras, video cameras or microscopes can be 
controlled by the program.  
 

2.2 Selection of devices 
 
To select the needed Twain device you have to use the menu item File > Select Source. A 
window appears listing all existing devices.   
 

 
Figure 1. Device selection window 
 
 
 



2.3 Scan  
 
Use the menu item File > Scan in order to open the desired device program for the creation 
and export of image files. 
 

   
Figure 2. Scan mask 

 
In figure 2 a control program of a Canon colour picture scanner is shown. 
Detailed operating instructions have to be extracted from the program documentation of the 
producer.  
In general you have to consider which colour mode or resolution of the target file is selected. 
The colour mode selection depends on how individual image objects differ from each other. If 
a greyscale analysis allows a clear differentiation so the mode Greyscale can be reasonable. 
Otherwise the mode Colour has to be selected. 
Concerning the image resolution you have to take into account that a higher resolution leads 
to a more precise analysis on the one hand. On the other hand it requires a longer processing 
time and more memory capacity. 
Devices used for enlarging images (e.g. microscope) require the input of a magnification 
factor. A corresponding window appears automatically or can be opened by the menu item 
Options > Magnification factor (see chapter 6.7). 
 

   
Figure 3. Input mask – magnification factor         Figure 4. Control mask - Mikokular (microscope) 
 
 
If the magnification factor is unknown, such as at photographs made by a digital camera, it is 
necessary to take a test photo with a scale (e.g. ruler). The magnification factor then can be 



determined on the basis of  the difference between the scale and the length measuring of the 
scale done by the program after scanning (see chapter 4.3).  
 

2.4 Twain input mask 
 
To use the Twain input mask of the selected Twain device you have to activate the option File 
> Show twain input mask. Otherwise it is tried to import the image on the basis of  standard 
settings : 
 
Scanner (default): 

· resolution 100 dpi 
· colour depth 24 Bit 
· width 210 mm 
· length 297 mm 

 
Mikrokular (microscope) 

· resolution 320 x 240 dpi 
· colour depth 24 Bit 

 

2.5 Filemanagement 

2.5.1 Open files 
 
By default the image file format MYP is offered. MYP is a program internal format, including 
a packed image without loss and additional needful information such as the magnification 
factor and more.  
Image files of the formats BMP and JPEG can be loaded too. In this case parameters 
concerning resolution, colour depth (menu item Options > dpi and resolution) or 
magnification factor have to be defined manually (see chapter 6.6 and 6.7). 
 

2.5.2 Close files 
 

By default image files are stored in the format MYP (see chapter 2.5.1).  
 
It is also possible to store it in a BMP format, but then all additional parameters 
(magnification factor …) get lost.  
 
Please note : The image of the work space is stored in WYSIWYG mode. If the image should 
have been changed, these changes are stored too, e.g. raster display or display mode 
black/yellow (see chapter 6.3 and 3.2). 
 

2.6 Create image objects 
 
This function provides the area computation of objects whose contours are captured by a 
graphic input device. 



2.6.1 Create images 
  
To create the image please select the menu item File > Create. 
  

 
Figure 5.: Creation of an image 

  
The creation of a drawing area (A2 – A5) requires a calibrating of the input device (see 
Calibrate input device ).  
Please note : This will be not necessary when using the function Copy pattern.  
 

2.6.2 Calibrate input devices 
 
With this function the resolution capability of the mouse is determined (DPI) . 
 

 
Figure 6.: Calibrate the input device 

  
1. Select calibration distance and unit 
2. Press the left mouse button and go along the section of measurements  

  
Press the button System parameters mouse in order to configure the mouse, if the resolution of 
the mouse should be too large. A DPI value bigger then 500 leads to a slowdown of the 
program execution, because the image size has to be matched with these settings. 
 
Select the button Finish Calibration for applying the determined settings. 



2.6.3 Draw objects 
 
It is possible to draw objects either on an empty work space (format DIN A2 – A5) or on a 
loaded template. 
 
Objects can be generated by two different methods :  

1)      Freehand 
2)      Connected lines 

  
1) Freehand 
Set the mouse on the object (arrow or the like) first, press the left mouse button then and go 
around the object with the mouse button keeping pressed.  
After releasing the button the starting point will be connected automatically with the end point 
and the object is filled. 
Please note : The starting point is located in the upper left region of the drawing area. The 
visible changes automatically when drawing (within the format definition A4, A5…). If the 
defined working space is left while drawing a system tone raises. 
Press the button Apply to make the created image available in the main program (only 
available in a full version) for an automatic computation of the object area. 
  
2) Connected lines 
Set the mouse on the object and press the left mouse button. The starting point is marked on 
the drawing area as a small black point. Move the mouse to the next object point and press the 
left button. The points are connected automatically. Additional points have to be marked in 
the same way. 
Press the right mouse button at last to connect the starting and end point. The object is filled 
automatically. 
Please note : Keep the left button pressed to activate the auto scroll function. In this case press 
the right button to mark single points. Both buttons have to be released to finish the process. 
Press the right button once again and the object will be shown as described above. If the 
defined work space is left a system tone raises.  
Press the button Apply to transfer the created image to the main program (only available in a 
full version) for an automatic computation of the object area. 
 
The NUM buttons 4,8,6 and 2 can also be used for scrolling. 

 
 
 
 
 
 
 
 
 
 
 
 
 



2.6.4 Video interface 
  
 
As shown in figure 8 it is possible to import images directly  
by diverse video equipment such as frame grabber, video grabber etc. 
 

 
Figure 8. Video  
  
Select the desired video input and please enter the camera resolution 
and magnification factor into the provided fields (seel also chapter 
7.2 Calibration). Press then the button 'Picture' to import 
the image as a snapshot in your programme. 
  
 

3. Work space (canvas) 
 
All images loaded or manually created are displayed on the canvas. Use the menu item Edit > 
Rotate 90 degrees to rotate the canvas by 90 degrees in a clockwise direction. This process 
can be repeated as often as the user need to. 
 
Additional menu options Edit (canvas) 

· Centre   centering the image on the canvas 
· Filter   selection of filters for image representation 

§ Nearest 
§ Linear 
§ Spline 
§ Lanczos 
§ Mitchell 

· Zoom    for zooming in and out 
· Cut and paste  to cut and paste a region marked by the mouse (keep right button 

pressed and shift mouse) 
· Toolbar image editing 



 

    
Figure 7. Canvas                     Figure 8. Toolbar 
 

3.1 Colour indication and defining of limit values for object identification 
 
Colour representation : 
When moving the mouse pointer over an image the colour ratio of the touched pixels will be 
shown in the fields Red, Green and Blue. To define a colour average of the relevant pixels 
keep the key STRG pressed simultaneously. The automatically calculated  average value will 
be buffered and also displayed in the fields Red, Green and Blue. Please press the key S to 
load the calculated average colour value into the window Limit values for object 
identification. 
 
 
 

 
Figure 9. Average colour values and positive/negative maximum values 

 



To apply the values shown in the fields Red, Green and Blue to the object identification you 
have to press the button Add ( see figure 9 ). The colour values and the reached minimum 
and/or maximum values are inserted into the table and are considered for the object 
identification. Generally it is possible to add more values here. 
 
When moving across the object it is advisable to enlarge the image in order to avoid to cross 
the object edge. 
Please note : Press the key R to delete all entries of the colour value buffer. So a new average 
colour value can be defined. 
 
The procedure just described can be carried out also directly in the mask Limit values for 
object identification. Look for the desired image detail ( if necessary zoom in ), keep the key 
STRG pressed and move with your mouse pointer across the part of the image whose limit 
value have to be determined. The result will be displayed in the right window by pressing the 
key S ( the option Preview has to be activated before).  To see the result already when moving 
the mouse across the image area you have to activate the option Apply limit values 
immediately. If the values shown in the fields Red, Green and Blue are to be used for the 
object identification, then please press the button Add. 
  
 
 

 
Figure 10. Analysis of three image regions and determination of the corresponding tolerance values for object identification 

 
Background identification : 
The determination of the entire object area requires a differentiation from background.  
Proceed analogously to the method described in section Colour representation and save all 
determined background colour values in the list Limit values for background identification. 
 
Greyscale representation: 
Principally the procedure is identically to those described before. Instead of the three basic 
colour values a grey tone is shown. Here not the colour average of the relevant pixels is 
determined, but the maximum value.  
 



 
Figure 11. Limit value for object identification in greyscale representation 

 
In figure 11 you can see some defined limit values for the identification of very dark (0-50) 
and bright (200-255) objects. 
 
Black-and-white representations: 
Only objects with a greytone of 0 (black) are identified. All other values are ignored. 
 

3.2 Apply limit values to images 
 
In order to apply the determined limit values (see chapter 3.1) to the image you have to 
activate the checkbox Apply limit values to the image.  A computation process starts and the 
result is shown in form of a black/yellow representation. Black means, that the object could be 
identified and used for the analysis. To check the identified objects you can press the button 
Original Image or the key [O]. So you can switch between both representations (original and 
black/yellow) very quickly.  
 

  
Figure 12. Original image and object identification 

 
Areas represented in grey had been identified as the background. This area will not be 
considered for the analysis (object area computation). The total object area (yellow and black) 
will be schown in the lower status bar. 



4. Analysis functions 

4.1 Area 
 
The area of all identified objects of the image is computed and displayed considering the 
selected unit of measurement (see chapter 6.2). The computation can be restarted by pressing 
the button Reset. 
An image detail can be picked for a more precise analysis. Mark the desired image detail with 
the right mouse button keep pressed or use the menu item Edit > Cut and paste.  
 
Within the representation of the applied limit values it is possible to click directly on the 
objects of interest. The corresponding area is computed and the selected object is displayed in 
another colour (Red). Furthermore the number of pixels is shown in the lower status bar. This 
value will be used in the process of an automatic object counting. 
 

 
Figure 13. Area computation of an object 

4.2 Density 
 
This function computes the proportion from object area (all identified object) to total image 
area. Press the button Computate (available only in mode yellow/black representation) to start 
this process. In general it provides the proportion from the object area ( yellow and black ) to 
the determined area (black). If you did mark single objects (by mouse click) then the 
proportion from the marked objects to the total object area (yellow and black) is provided. 
 

4.3 Length 
 
A manual measurement of the object length can be made by the left mouse button keeping 
pressed. The length of the covered line will be shown in the field Length depending on the 
defined unit of measurement.  



All measured values will be added simultaneously in the field Total. Press the button Reset in 
order to reset the calculated value.  
 
To start an automatic calculation of the length of all identified objects please press the button 
Calculate (only available in the yellow / black representation ). As a result you will see the 
contours of the corresponding objects on the image (see chapter Length determination of plant 
roots ). 
 

 
Figure 14. Automatic object length calculation 
 

 4.4 Object counting 
 
With this function all identified objects can be counted automatically. The number of objects 
can be reduced by using the options Minimum number of pixels per object and  Maximum 
number of pixels per object . Click on the single object to determine its number of pixels. 
 

 
Figure 15. Object counting 
 

This function is only available in the yellow / black representation. All counted objects can be 
displayed in red colour by pressing the button Show objects.  
 



 
Figure 16. Presentation of the counted objects 

4.4.1 Settings for object counting of overlapping objects 
 
The separation of overlapping object can be made by comparison of either object surfaces or 
intensities. In addition, there is the possibility to separate circular or ellipsoidal objects by 
means of object recognition. 
 

 
Figure 17. Settings for object separation 

 



4.4.1.2 Separation of overlapping objects by object area comparison 
 
The reference area can be specified by hand. The specification is made in pixel. It’s best to 
click on the reference object within the yellow/black presentation to determine the number of 
object pixels and to fill it into the corresponding field automatically. 
 
The second possibility for specifying a reference area is to determine either the average value 
or the median of the object areas. All objects fulfilling the conditions described in chapter 4.4 
are now compared with the reference area.  Whole divisors are increasing the object counter, 
the remainder will be treated depending on similarity defaults (sliding control). 
 
 

 
Figure 18. Object separation  by using the average value of object areas 

 

4.4.1.3 Separation of overlapping objects by intensity comparison 
 
Another way for counting overlapping objects is by using the object intensity. This option is 
available individually or combined with area separation (chapter 4.4.1.2) or object recognition 
(chapter 4.4.1.3). Completely overlapping objects so can be counted separately providing that 
the resulting intensity differs from the intensity of the single objects. 
 
If both options (intensity and object area) are used the separation by object area comparison 
takes priority. This means that only objects are treated by intensity comparison which could 
not be separated by object area comparison. The sensitivity of the intensity comparison (total 
intensity of all objects, AVG and/or median) to the average object intensity can be controlled 
by means of a sliding control.  

 
 
 
 



4.4.1.4 Separation of overlapping objects by object recognition  (circle or ellipse)  
 

 
Figure 18 a : Object recognition 

 
Overlapping circular objects can be identified by the detection of irregularities in object 
shape. A fault tolerance can be defined for small deviations (eg caused by an uneven object 
surface). Only after exceeding this value a deviation of the direction will be classified as a 
new object. 
  

4.5 Number of intersection points with a raster 
 
Here the intersection points of the objects with a raster are determined. The raster distance is 
selectable. This is used for instance for the determination of root length after Tennant.  
(Tennant D (1975) A test of a modified line intersect method of estimating root length) 
 
Switch into raster mode:  
 

 
Figure 19. Selection of analysis method 
 
The raster parameters can be set with the menu item Options > Raster width.  
 
The counted intersections are marked red in the raster. The raster is put automatically over the 
image when pressing the button Reset or with image change. The raster can be deleted by 
pressing the left mouse button. It is also possible to count only within a part of the image. 
Mark the desired part with the right mouse button (see also chapter 6.3). 
 



 
Figure 20. Image with counted intersection points  

 

4.6 Manual counter 
 
Here the objects can be counted manually (see also chapter 6.9). 

 
Figure 21.: Scan method manual counter 
 
 

Please select Options > Scan method> Manual counter . 



Afterwards you can specify the size of marking with Options > Marker. This is a circle, 
which is drawn around the clicked area. The colour of marking can be set over Options > 
Marker > Colour for marking.  
  
With every left mouse button click the corresponding position will be marked and the counter 
counted up. The last counting can be reset if you press the Button Undo. 
Please press the button Reset if you want to delete the image and counter. 
 

 
Figure 22.: Manually counted cell nucleus 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



5. Colour distribution  
 
This function provides an analysis of the colour distribution of  the working space. This can 
be helpful to determine the limit values for object identification. 
 
 

 
Figure 23. Colour distribution 3D view 

 
The „Maneuvering “ within the representation can be done over a bar of buttons or by mouse. 
 

  
Figure 24. Button bar 

 
For zooming in and out please use the corresponding loupe buttons. For marking a specific 
part you have to mark it by mouse with the left button keep pressed.  
For scrolling please use either the corresponding arrow buttons or the mouse function when 
keeping the right button pressed. 
 
A changing between work space and colour distribution view can be made by the menu 
options Extras > Determine colour distribution or Extras > Show work space. 
 

6. Settings 

6.1 Limit values for object identification 
 
All limit values for object identification determined manually or automatically for the colour 
and/or grey tone analysis can be managed here(see 2.3.1). The values are stored at the  end of 
the program and loaded automatically with the next start. 
 
 
 



6.2 Units 
 
The following units of measurement for the output of the result can be selected : meter, 
millimetre, centimetre and/or inch. 

6.3 Cursor and raster 
 
When marking an image region or measuring the object length by mouse, the marked region 
is drawn. These markings get lost when releasing the mouse button. To show it permanently 
use this menu option. 
 
When counting intersection points the raster used is placed on the image. The drawing can be 
switched off too. 
 

6.4 White balance 
 
With this function an automatic image import is made by the selected device. No objects 
should be located on the image. The maximum values of the found pixels (grey tone) are 
indicated and can be used for a better definition of limit values in the process of the object 
identification. Ideally the value should be 255 (white) for a scanner, that means no objects 
(e.g. dust) was found. If the determined value should be smaller than 255, then an object 
identification is only possible below the measured value. 
 
For example :     
 

 
 

 
Figure 25. Recommended threshold value for object identification 

 
A detailed evaluation can be made by the chart of the colour distribution (see also chapter 5). 
 



 
Figure 26. Colour distribution - total and a range around the grey tone 74 

 

6.5 Language 
 
The offered program languages are German and English.  

 

6.6 Dpi and colour depth 
 
To set the required  resolution and colour depth you can use this menu item. 
When creating images by a twain interface or loading MYP images this will be done 
automatically. The loading of formats like BMP and JPEG requires a manual input of these 
values. The results of the analysis depends directly on the parameter settings for image 
resolution  
 

 
Figure 27. Resolution and colour depth 

 

6.7 Magnification coefficient 
 
The magnification coefficient as well has a big influence on the analysis results. The manual 
input is required if images are created by a microscope or a digital camera (see chapter 2.3). 
 
 
 



6.8 Scan method 
 
Use this menu item to select one o the following analysis method : 
* 2D area calculation or  
* counting raster intersection points (see chapters 4.1 and 4.5). 
 

6.9 Save image data 
 
If this option is selected, the user will be requested for saving the image date after scanning or 
creating. So the original image data can be stored automatically. 
 

7. Extra 

7.1 Cut and count 
 
This menu item provides a tool for the manual counting of image objects. The current image 
file will be divided into subframes according to the setting given in field Cut after. 
 

 
Figure 28. Setting for image cutting 

 
Press the button Cut in order to cut the image and to reset the counter readings. 
 

 
Figure 29. Cut and count 
 
All subframes are listed in the left scrollbox. The active frame marked with a red border will 
be displayed on the work space. 



In the example shown in figure 29 the image was cut into 15 subframes. By means of the keys 
5 (forward) and 4 (back) a change of the active subframe is possible. The counter will be 
updated by the keys + or -.  
All functions can be controlled over a popup menu. 
 

  
Figure 30. Popup menu – right mouse button 

 
Press the button Reset counter in order to reset the counter of the active subframe. 
 

 
 
The total counter reading will be shown after reaching the last subframe. 
 
 

7.2 Calibrate 
 
With the help of this function the DPI parameters can be matched with the actual proportions. 
This will be necessary for instance if the magnification factor of a digital camera is unknown. 
An image containing a scale is needed here (see figure 31). 
 

 
Figure 31. Image calibration by scale 



1. Select calibration distance and unit  
2. Press the left mouse button and go along the line 
3. Press the button Finish calibration at the end 

  

8 ? 

8.1 Registration 
 
Here the user is requested to enter his registration data. Please enter the received licence 
number and registration name. After a successful validation the demo program will be 
converted to a full version. 

 
Figure 32.: Registration 

 

8.2 Help  
 
Call of the help document. 

 

8.3 Update 
 
This function automatically look for new Updates of the GSA Image Analyser. 
 

 
 
New versions can be installed into the same program directory as the previous version. 
Personal settings and the registration key remain unaffected by the update installation.  
 

 
 


